Intellicus Enterprise Reporting and Business Insights 19.0

Design Process

0 views June 28, 2020 0

Upon launching Intellicus Desktop Studio, the Welcome to Intellicus Desktop Studio dialog box appears.

dialog box
Figure 5: Welcome to Intellicus Desktop Studio Dialog Box

On this Welcome to Intellicus Desktop Studio dialog box, you can decide to do any of the following:

  • Use any of the pre-designed reports and modify as per requirement
  • Create a new report (without or with using wizard)

Choosing to open a pre-designed (existing) report

Under Open, select Existing Report to open a report that was already created. Double-click the report if it is available in the list or double-click Browse… to browse and select the report.

On Welcome… dialog box, click OK after selecting the report. The selected report opens in Intellicus Desktop Studio.

You can also open an existing report by File > Open > Select the report from the saved location > Open. The selected report opens in Intellicus Desktop Studio.

Choosing to create a new report

Under Create, click New Report option. You can also create a new report by File > New > SQL Report > Blank Report.

You can then design the report manually using the SQL Designer as per requirement. For more information refer to the Desktop Studio – SQL Designer document.

You can design reports using the SQL Report Wizard with the use of predefined layouts and templates. For more information on designing the reports with the help of SQL Report Wizard, refer to SQL Report Wizard section.

SQL Report Wizard

The SQL report wizard provides an easy-to-use tabbed interface to create a report. If your report is simple/tabular/form having a lot of components on it, it is always a good idea to start designing a new report using the report wizard. A report that does not have chart or cross-tab can be entirely designed using report wizard. If a report has chart or cross-tab then it is a nice idea to use report wizard for some of the activities.

Select File > New > SQL Report. The SQL Report Wizard window appears. The report wizard provides the following tabs:

Report Wizard
Figure 6: Report Wizard

  • Report Type: To specify report title and layout related information.
  • SQL Source: To specify SQL data source related details (for SQL based reports).
  • Fields: To specify the fields to be placed on the report.
  • Groups: To specify group related information.
  • Totals: To specify summary (totals) related information.
  • Style: To specify Styles (pre-set formatting) related information.
  • Sub Reports: To specify and provide sub report related information. For more information on sub-reports, refer to Desktop Studio – Sub-Reports document.

For more information on creating reports using SQL Wizard, refer to section Create Reports using Wizard section in Desktop Studio – Beginners Guide .

The reports created are saved with .irl extension, that is, Intellicus Report Layout.

Once the reports are created using SQL Wizard, you can open the saved report from File > Open and work on further designing it using additional control options. The report contains sections such as report header, report footer, page header, page footer, group header, and group footer.

design

You can do the following actions:

Once you have completed designing the report, you can preview the report by clicking Preview. You can save the report by clicking Save icon and upload the report by clicking Upload icon (for more information on controls and the icons used to place these controls, refer to section Toolbars) .

Now, you can open the designed report from the Intellicus Application through Explorer > < Select Report > Run Report. The report will run successfully. Click View Now to view the report according to how it is designed.

You can export the designed reports to different file formats like PDF, Excel, CSV, Text, and Word. For more information on exporting reports to different formats, refer to Desktop Studio – Beginners Guide .

Creating SQL Report without using Wizard

To create an SQL report layout, you need to configure the database connectivity. This will enable you to retrieve data from the desired tables.

Refer to the document “DesktopStudio-SQLDesigner” for more information.

Set the Database Connectivity

All database related tasks in a report can be performed only after setting a database  connection for the current report.  Each report opened in the Intellicus Studio has its own connection. To open the Database Connections dialog, from menu, select Tools > Connections.  You can also click  button from the toolbar.

Report Wizard
Figure 9: Connecting to a Database

The dialog box lists the connections setup in Intellicus Report Server.  For each entry in the list, following information is displayed:

  • Name: Unique name to identify the connection.
  • Valid: A tick indicates that the connection was valid when Desktop Studio was launched.
  • IsRunTime: A tick indicates that user credentials for the database server will be asked at runtime. If you try to set this connection for the report, you will be required to provide user credentials now also.
  • Connect String: String that will be used to get connected with the database server.
  • Set for all child objects: If this check box is selected (checked) all the child objects (if any) of this report will use this connection.

Name, Valid, IsRunTime and Connect String are read-only.

This dialog box lists the connection strings that have been configured earlier.

Note: Database connections are configured using the Web Interface.

Now,

  1. Select the connection by clicking in the first column of the corresponding row. The entire row gets selected.
  2. Click the Set
  3. Click OK to save the changes and close the dialog box. If the connection set has a tick in Runtime column, then Connect To dialog box will appear.  Specify user credentials and click Connect to go ahead.

Database Connection dialog box is closed and the connection is set as the active database connection for the report.

To refresh metadata caching

Metadata is cached at the time of launching Desktop Studio.  To refresh the metadata manually,

  1. Select the data connection for which metadata needs to be refreshed.
  2. Click Refresh Schema
  3. Click Yes on the confirm refresh dialog box to proceed.

When you click Yes, a request is sent to the report server to get the metadata information for the selected database connection.

Important: You need to have super administrator privileges to be able to manually refresh the schema.

Data from Multiple Data Sources

Generally a report gets its data from one connection (data source).  However, a report may get data from multiple data sources.  You may use different SQLs (but same data connection) to get data for different components of a report. You can use separate query as well as data connection for chart, cross-tab, and sub report.