Intellicus Enterprise Reporting and Business Insights 19.0

Beginner's Tasks

0 views June 28, 2020 0

This chapter provides you information on designing your report using the GUI (Graphical User Interface). The Layout Editor provides you with a facility to design a report using simple report generation tools. You can add fields and sections to your report, use formatting features and parameters to generate simple and complex reports. You can also modify or delete the performed actions.

The Explorer window displays all the sections and their controls in a hierarchy. If you select any value in this window, that value will get selected in the layout pane. Click View -> Explorer to show/ hide this window.


Figure 10: The layout editor

Fields Pane

The field window displays all the fields from the selected tables, along with the defined parameters if any.

In order to update the fields listed in this window, you need to click Refresh Fields button or from View menu, click Refresh Fields option to get the updated values displayed in this window. You can simply drag the fieldnames from this window to the report layout pane.

When you drag a field from Fields List, Intellicus will also place its caption in the header section.

Click View > Fields to show / hide this window.

Layout Pane (Layout Window)

The layout pane contains the broad sections under which the fields will be arranged. To add fields to this pane drag the fields into this pane from the field window. You can also insert parameter values, and field controls to this pane.

To change any properties of the added controls (fields), click that control and change its properties from the Properties list.

Properties Pane

You can modify/ view the property set for the controls / sections on the layout pane for each selected object.

Click View > Properties to show/hide this window.

 

 

 

Hyperlinking
Hyperlink the field to open a specific URL
  1. Open the report in which hyperlinking is to be done.
  2. Right click on the component to be hyperlinked, and click Hyperlink or press Ctrl+K.Click URL radio button.
  3. In the comment textbox provided below URL radio button, enter the URL.
  4. Click Apply and click OK. When you open the report and click on the hyperlink, it directs you to the hyperlinked URL.
Hyperlink the field to open a specific report
  1. Open the report in which hyperlinking is to be done.
  2. Right click on the component to be hyperlinked, and click Hyperlink or press Ctrl+K.
  3. Click DrillDown to another report radio button.
  4. Select the report to be opened when the hyperlink is clicked from Select drop-down.
  5. Select the most appropriate option for Target with which the report opens. The values are New Window, Same Frame, Parent Frame, and Parent Window. Refer to the Details of hyperlink window Target.
  6. Specify Report Parameter and the value field if the report needs any report parameters to run. 

    Note:Report Parameter is the parameter in the report being set as hyperlink. Value field is the field within the report that will have the hyperlink.

  7. Specify System Parameter and the value field if the report needs any system parameters to run.
  8. Specify Save File Name to use when the report is implicitly published.
  9. Click Apply and click OK.

You can design a new report template and save it as .irt file or you can open an existing report template, modify, rename, and save it.

To create a new template

new template
Figure 2: Create New Template

  1. On Intellicus Studio click the File > New button from the toolbar.
  2. Click SQL Report or press Ctrl+N.

sql report
Figure 3: SQL Report Wizard

  • Click Blank Report. If you have just launched Intellicus Studio and if the Welcome dialog box appears, de-select the Use Wizard check box and click OK.
  • Design the template.
  • Click Save As to save the template in the location IntellicuswinclientStudioTemplatesSimpleTabular.
  • Save the file as type .irt.
  • Click Save.

The process of creating a template is the same as that of creating a report layout, which involves:

  • Adding sections
  • Placing dynamic controls and static controls on different sections of the template
  • Setting properties of controls, including other activities.

For more information, refer to Desktop Studio – Sections and Control Properties document.

The Report Templates created are stored at IntellicusStudioTemplatesSimpleTabular. To open the Report Templates, perform the following:

template file
Figure 4: Opening a template file

  1. From the File menu, click Open.
  2. In the File Name text box, specify “*.irt” to get a list of template files available in the active folder.
  3. Browse the folder where template files are stored. Default folder is IntellicusStudioTemplatesSimpleTabular.
  4. From the list, select the file on which you want to work and click Open. The selected file opens in Intellicus Studio.